Rename RunnableStory to Embeddable and remove redundant methods

Description

The name RunnableStory has become outdated and does not reflect the fact that we can run multiple stories or even have access to other Embedder functionality. Embeddable is a more generic name that's better suited.

The two methods that should remain in Embeddable are:

void useEmbedder(Embedder);
void run();

The other methods that were previously in RunnableStory can live in abstract implementations, such as ConfigurableEmbedder which JUnitStory extends and allows the configuration of the embedder for execution of a single story.

Assignee

Mauro Talevi

Reporter

Mauro Talevi

Labels

None

Components

Fix versions

Priority

Minor
Configure